Elevated 3DS Errors for Mastercard

Incident Report for Silverflow

Resolved

As of 10:10 CET, we have seen full recovery in Mastercard 3D Secure Authentications.
Posted Jul 15, 2026 - 11:10 CEST

Monitoring

Mastercard has acknowledged an ongoing issue on their end, affecting 3D Secure authentications starting from 08:59 CET. We will keep monitoring until Mastercard has resolved the issue on their end.
Posted Jul 15, 2026 - 09:53 CEST

Identified

At around 09:00 CET we noticed an increase in Mastercard 3DS 5xx errors. At this moment this is still ongoing and no Mastercard 3DS request are successful. We have reached out to Mastercard and will continue monitoring.
Posted Jul 15, 2026 - 09:44 CEST

Investigating

We are currently observing a high rate of failing 3DS requests for Mastercard.
Posted Jul 15, 2026 - 09:29 CEST