Degraded performance on Mastercard 3DS Challenge Flow

Incident Report for Silverflow

Resolved

As of 13:03 CET the issue of not being able to complete the Mastercard 3D Secure Challenge flow has been resolved. All Mastercard 3D Secure services are now operating as expected. We will continue monitoring our systems to ensure ongoing stability.
Posted Jul 15, 2026 - 13:19 CEST

Identified

Mastercard has Acknowledged that the issue is on their side. We are waiting for them to resolve the issue and will keep monitoring.
Posted Jul 15, 2026 - 11:57 CEST

Investigating

As of 10:54 CET we have identified an issue with completing the Mastercard 3D Secure challenge flow. We have reached out to Mastercard and will continue monitoring.
Posted Jul 15, 2026 - 11:41 CEST