Silverflow customerportal.silverflow.com Temporarily Unavailable to Some Customers

Incident Report for Silverflow

Resolved

Status
As of 0900hrs CET on December 15, 2025, Silverflow customerportal.silverflow.com is fully operational. The third party provider for our customer ticketing portal has resolved the issue on our ticketing portal which resulted from a configuration issue their database.

Next Steps
All customers that have a login to customerportal.silverflow.com can now fully access their tickets.
Posted Dec 15, 2025 - 12:48 CET

Update

Status
We continue to work with our 3rd party provider of our helpdesk ticketing portal to resolve the issue.

Next Steps
Please use support@silverflow.com to log any tickets.
No Silverflow processing components are affected, and only our 3rd party helpdesk ticketing portal is affected.
Posted Dec 11, 2025 - 22:24 CET

Identified

Status
As of 1500hrs CET on December 11, 2025, Silverflow customerportal.silverflow.com is temporarily unavailable to some Silverflow customers. If you need to create a ticket, please use our support@silverflow.com email address for now. The provider for our customer portal is partly down and that has impacted the access to the Silverflow Customer Portal. Tickets can still be created, however some of our customers may not be able to access the customer portal until this disruption has been resolved.

Next Steps
We are working closely with our helpdesk ticketing system provider to urgently resolve this issue.
No other Silverflow systems or services are affected.
Posted Dec 11, 2025 - 18:24 CET