Elevated 3DS Error Rates

Incident Report for Silverflow

Resolved

Between 16:37 and 16:55 CEST, we experienced an issue where 51.30% of all Mastercard 3DS requests failed across multiple issuers. Our investigation confirmed this was caused by an influx of improperly formatted error messages received directly from Mastercard.

The issue subsided at 16:55 CEST, and our monitoring confirms that 3DS authentication for Mastercard has remained fully stable since then.
Posted Jul 12, 2026 - 17:41 CEST

Monitoring

Our engineering team has identified that the elevated 3DS error rates were caused by an influx of invalid error messages originating from Mastercard.
These errors subsided at approximately 16:56 CEST. We are now actively monitoring the situation to ensure full stability is maintained.
Posted Jul 12, 2026 - 17:11 CEST

Investigating

We are currently observing a high rate of failing 3DS requests. Our engineering team is actively investigating
Posted Jul 12, 2026 - 16:52 CEST